aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-08 12:52:09 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-08 12:52:09 +0200
commitee2b355d788b070a7e57dc6e36b973a7bf8478ea (patch)
tree51c51eb9cd60bff929b56933f0b2439391ba4a82
parentkeyrings.inc.bash: avoid the SHA1 warning (diff)
downloadqa-scripts-ee2b355d788b070a7e57dc6e36b973a7bf8478ea.tar.gz
qa-scripts-ee2b355d788b070a7e57dc6e36b973a7bf8478ea.tar.bz2
qa-scripts-ee2b355d788b070a7e57dc6e36b973a7bf8478ea.zip
gpyutils: Add 312-to-313.txt
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--Makefile.gpyutils12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.gpyutils b/Makefile.gpyutils
index 75fee4e..fafc1ba 100644
--- a/Makefile.gpyutils
+++ b/Makefile.gpyutils
@@ -22,12 +22,22 @@ upgr_txt = $(upgr_base) $(upgr_streq)
upgr_dot = $(patsubst %.txt,%.dot,$(upgr_txt))
upgr_svg = $(patsubst %.dot,%.svg,$(upgr_dot))
# add new impls here if not stable yet, to avoid insanely huge generation times
-upgr_all = $(upgr_txt) $(upgr_dot) $(upgr_svg)
+upgr_all = $(upgr_txt) $(upgr_dot) $(upgr_svg) $(outdir)/312-to-313.txt
all = $(upgr_all)
all: $(all)
+$(outdir)/312-to-313.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-upgrade-impl -m python3_12 python3_13 > $@.new
+ mv $@.new $@
+
+$(outdir)/312-to-313-stablereq.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-upgrade-impl -m -s python3_12 python3_13 > $@.new
+ mv $@.new $@
+
$(outdir)/311-to-312.txt: $(timestamp)
mkdir -p $(outdir)
gpy-upgrade-impl -m python3_11 python3_12 > $@.new