summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-07-17 13:40:55 -0700
committerMatt Turner <mattst88@gentoo.org>2020-07-17 14:19:08 -0700
commita5ddc21c484ac8a4e5515e853cc6fe5b28dd7e76 (patch)
tree51b52ae399cf592ca53d85ee53e5112521e8d7b7 /sys-process/systemd-cron
parentsys-process/systemd-cron: Add Python 3.8 and 3.9 compatibility (diff)
downloadgentoo-a5ddc21c484ac8a4e5515e853cc6fe5b28dd7e76.tar.gz
gentoo-a5ddc21c484ac8a4e5515e853cc6fe5b28dd7e76.tar.bz2
gentoo-a5ddc21c484ac8a4e5515e853cc6fe5b28dd7e76.zip
sys-process/systemd-cron: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-process/systemd-cron')
-rw-r--r--sys-process/systemd-cron/Manifest1
-rw-r--r--sys-process/systemd-cron/files/1.5.12-generatordir.patch67
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.5.12-r1.ebuild78
3 files changed, 0 insertions, 146 deletions
diff --git a/sys-process/systemd-cron/Manifest b/sys-process/systemd-cron/Manifest
index 054d8089a53c..b8b1e37e82cc 100644
--- a/sys-process/systemd-cron/Manifest
+++ b/sys-process/systemd-cron/Manifest
@@ -1,2 +1 @@
-DIST systemd-cron-1.5.12.tar.gz 31417 BLAKE2B d0776d2c4aa2d86289dd8ab5dade47f083ee7abc16f54c9527130f587049064d6100eaccd4a3a0a461d21ac8286910d3cb0590db14ea1d3a32e591b7ede0a59e SHA512 6f85cef0870cde5ff6b397fb640a30a8a567e09e3cac48456498f1f102395f12f174731ca9cc8e826bb6c49a0d3a6dd49a9aec63e7b75648b7dccfaa499dcea4
DIST systemd-cron-1.5.14.tar.gz 31634 BLAKE2B 59394128145dbd04a2b1bb10a6ac8821a97a465e3c0d43f3ca8fdfe60db273352d46b1200c966adaf772272835269c5c553b040cb0e0340ec56340181c9b7245 SHA512 772a4f8181a0f8039a8138fdc43bfe0f2bd89222fe19fa971727be265036f86435334d6230e116440f6969425fc6d59dc26e9cf230c00d030ea5d62ba351713c
diff --git a/sys-process/systemd-cron/files/1.5.12-generatordir.patch b/sys-process/systemd-cron/files/1.5.12-generatordir.patch
deleted file mode 100644
index 71c0abd4d804..000000000000
--- a/sys-process/systemd-cron/files/1.5.12-generatordir.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From e9c1dcd5e1a475a1974f0a6464637c4ab731bfae Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Sat, 13 Jan 2018 11:42:05 -0500
-Subject: [PATCH] Replace remaining references to
- @libdir@/systemd/system-generators
-
----
- Makefile.in | 1 +
- src/bin/crontab.py | 2 +-
- src/man/systemd-crontab-generator.8.in | 6 +++---
- 3 files changed, 5 insertions(+), 4 deletions(-)
-
-diff --git a/Makefile.in b/Makefile.in
-index b9a9b02..e5a2df8 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -60,6 +60,7 @@ define in2out
- -e "s|\@bindir\@|$(bindir)|g" \
- -e "s|\@libdir\@|$(libdir)|g" \
- -e "s|\@unitdir\@|$(unitdir)|g" \
-+ -e "s|\@generatordir\@|$(generatordir)|g" \
- -e "s|\@runparts\@|$(runparts)|g" \
- -e "s|\@version\@|$(version)|g" \
- -e "s|\@persistent\@|$(persistent)|g" \
-diff --git a/src/bin/crontab.py b/src/bin/crontab.py
-index d95b31e..921db1a 100755
---- a/src/bin/crontab.py
-+++ b/src/bin/crontab.py
-@@ -333,7 +333,7 @@ if __name__ == '__main__':
- 'show': show,
- }.get(args.action, replace)
-
-- loader = importlib.machinery.SourceFileLoader('name', '@libdir@/systemd/system-generators/systemd-crontab-generator')
-+ loader = importlib.machinery.SourceFileLoader('name', '@generatordir@/systemd-crontab-generator')
- parser = loader.load_module()
-
- action(cron_file, args)
-diff --git a/src/man/systemd-crontab-generator.8.in b/src/man/systemd-crontab-generator.8.in
-index ea69688..dedf1d2 100644
---- a/src/man/systemd-crontab-generator.8.in
-+++ b/src/man/systemd-crontab-generator.8.in
-@@ -4,7 +4,7 @@
- systemd-crontab-generator - translate cron schedules in systemd Units
-
- .SH SYNOPSIS
--@libdir@/systemd/system-generators/systemd-crontab-generator output_folder
-+@generatordir@/systemd-crontab-generator output_folder
-
- .SH DESCRIPTION
- systemd-crontab-generator is a generator that translates the legacy cron files (see FILES)
-@@ -77,11 +77,11 @@ to have a overview of timers and know when they will elapse.
-
- If you get errors like
- .br
--.B @libdir@/systemd/system-generators/systemd-crontab-generator failed with error code 1.
-+.B @generatordir@/systemd-crontab-generator failed with error code 1.
- .br
- in the journal, you can manually run
- .br
--.B "@libdir@/systemd/system-generators/systemd-crontab-generator /tmp"
-+.B "@generatordir@/systemd-crontab-generator /tmp"
- .br
- to get a more verbose error message.
-
---
-2.16.0.rc0
-
diff --git a/sys-process/systemd-cron/systemd-cron-1.5.12-r1.ebuild b/sys-process/systemd-cron/systemd-cron-1.5.12-r1.ebuild
deleted file mode 100644
index b16de1a1a9a1..000000000000
--- a/sys-process/systemd-cron/systemd-cron-1.5.12-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( pypy3 python3_6 )
-inherit eutils python-single-r1 systemd
-
-DESCRIPTION="systemd units to create timers for cron directories and crontab"
-HOMEPAGE="https://github.com/systemd-cron/systemd-cron/"
-SRC_URI="https://github.com/systemd-cron/${PN}/archive/v${PV}.tar.gz -> systemd-cron-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 sparc x86"
-IUSE="cron-boot etc-crontab-systemd minutely setgid test yearly"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=sys-apps/systemd-217
- sys-apps/debianutils
- !etc-crontab-systemd? ( !sys-process/dcron )
- ${PYTHON_DEPS}
- sys-process/cronbase"
-
-DEPEND="sys-process/cronbase
- test? ( sys-apps/man-db dev-python/pyflakes )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_prepare() {
- epatch "${FILESDIR}/1.5.12-generatordir.patch"
-
- python_fix_shebang --force "${S}/src/bin"
-
- sed -i \
- -e 's/^crontab/crontab-systemd/' \
- -e 's/^CRONTAB/CRONTAB-SYSTEMD/' \
- -- "${S}/src/man/crontab."{1,5}".in" || die
-
- sed -i \
- -e 's!/crontab$!/crontab-systemd!' \
- -e 's!/crontab\(\.[15]\)$!/crontab-systemd\1!' \
- -e 's/pyflakes3/pyflakes/' \
- -- "${S}/Makefile.in" || die
-
- if use etc-crontab-systemd
- then sed -i \
- -e "s!/etc/crontab!/etc/crontab-systemd!" \
- -- "${S}/src/man/crontab."{1,5}".in" \
- "${S}/src/bin/systemd-crontab-generator.py" || die
- fi
-
- epatch_user
-}
-
-my_use_enable() {
- if use ${1}; then
- echo --enable-${2:-${1}}=yes
- else
- echo --enable-${2:-${1}}=no
- fi
-}
-
-src_configure() {
- ./configure \
- --prefix="${EPREFIX}/usr" \
- --confdir="${EPREFIX}/etc" \
- --runparts="${EPREFIX}/bin/run-parts" \
- --mandir="${EPREFIX}/usr/share/man" \
- --unitdir="$(systemd_get_unitdir)" \
- --generatordir="$(systemd_get_systemgeneratordir)" \
- $(my_use_enable cron-boot boot) \
- $(my_use_enable minutely) \
- $(my_use_enable yearly) \
- $(my_use_enable yearly quarterly) \
- $(my_use_enable yearly semi_annually) \
- $(my_use_enable setgid) \
- --enable-persistent=yes
-}