summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-10-03 09:57:09 +0000
committerTim Harder <radhermit@gentoo.org>2012-10-03 09:57:09 +0000
commit44f497471f87569b21db02819da06bd7bdf3b758 (patch)
tree992a08a99baadb835900a2e5620089f16a000899 /media-gfx/apngasm
parentVersion bump. (diff)
downloadhistorical-44f497471f87569b21db02819da06bd7bdf3b758.tar.gz
historical-44f497471f87569b21db02819da06bd7bdf3b758.tar.bz2
historical-44f497471f87569b21db02819da06bd7bdf3b758.zip
Version bump.
Package-Manager: portage-2.2.0_alpha134/cvs/Linux x86_64
Diffstat (limited to 'media-gfx/apngasm')
-rw-r--r--media-gfx/apngasm/ChangeLog7
-rw-r--r--media-gfx/apngasm/apngasm-2.7.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/media-gfx/apngasm/ChangeLog b/media-gfx/apngasm/ChangeLog
index b8d39f8d980e..d09d06c692e2 100644
--- a/media-gfx/apngasm/ChangeLog
+++ b/media-gfx/apngasm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/apngasm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngasm/ChangeLog,v 1.7 2012/05/05 07:00:20 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngasm/ChangeLog,v 1.8 2012/10/03 09:52:37 radhermit Exp $
+
+*apngasm-2.7 (03 Oct 2012)
+
+ 03 Oct 2012; Tim Harder <radhermit@gentoo.org> +apngasm-2.7.ebuild:
+ Version bump.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> apngasm-2.5.ebuild,
apngasm-2.6.ebuild:
diff --git a/media-gfx/apngasm/apngasm-2.7.ebuild b/media-gfx/apngasm/apngasm-2.7.ebuild
new file mode 100644
index 000000000000..d0b11ee0abb4
--- /dev/null
+++ b/media-gfx/apngasm/apngasm-2.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngasm/apngasm-2.7.ebuild,v 1.1 2012/10/03 09:52:37 radhermit Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="create an APNG from multiple PNG files"
+HOMEPAGE="http://sourceforge.net/projects/apngasm/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng[apng]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS="$($(tc-getPKG_CONFIG) --libs libpng --libs zlib)" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}