summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-25 14:15:10 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-25 14:15:10 +0000
commitb4e27759d8e6a17b3ec7632317b5942518b2caf0 (patch)
tree8d86ce71d23925f77107b2da67c326d6f49649cf /media-plugins/xmms-shell
parenttouchups (diff)
downloadhistorical-b4e27759d8e6a17b3ec7632317b5942518b2caf0.tar.gz
historical-b4e27759d8e6a17b3ec7632317b5942518b2caf0.tar.bz2
historical-b4e27759d8e6a17b3ec7632317b5942518b2caf0.zip
touchups
Diffstat (limited to 'media-plugins/xmms-shell')
-rw-r--r--media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild25
1 files changed, 8 insertions, 17 deletions
diff --git a/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild b/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild
index 0e3224ff20f8..6ec107618127 100644
--- a/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild
+++ b/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild
@@ -1,20 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild,v 1.5 2003/02/13 13:04:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild,v 1.6 2003/04/25 14:15:10 vapier Exp $
-IUSE="readline"
-
-
-S=${WORKDIR}/${P}
-DESCRIPTION="XMMS-Shell is a simple utility to control XMMS externally."
+DESCRIPTION="simple utility to control XMMS externally"
SRC_URI="http://download.sourceforge.net/xmms-shell/${P}.tar.gz"
HOMEPAGE="http://www.loganh.com/xmms-shell/"
-DEPEND=">=media-sound/xmms-1.2.7
- readline? ( >=sys-libs/readline-4.1 )"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
+IUSE="readline"
+
+DEPEND=">=media-sound/xmms-1.2.7
+ readline? ( >=sys-libs/readline-4.1 )"
src_unpack() {
unpack ${A}
@@ -23,18 +21,11 @@ src_unpack() {
}
src_compile() {
- local myconf
-
- use readline \
- && myconf="${myconf} --with-readline" \
- || myconf="${myconf} --without-readline"
-
- econf ${myconf} || die "./configure failed"
+ econf `use_with readline` || die
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
-
dodoc AUTHORS README
}