summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/cutg/ChangeLog8
-rw-r--r--sci-biology/cutg/cutg-160.ebuild16
-rw-r--r--sci-biology/emboss/ChangeLog11
-rw-r--r--sci-biology/emboss/emboss-6.1.0-r1.ebuild110
-rw-r--r--sci-biology/meme/ChangeLog8
-rw-r--r--sci-biology/meme/meme-4.3.0-r1.ebuild64
-rw-r--r--sci-biology/primer3/ChangeLog11
-rw-r--r--sci-biology/primer3/primer3-1.1.4-r1.ebuild40
8 files changed, 254 insertions, 14 deletions
diff --git a/sci-biology/cutg/ChangeLog b/sci-biology/cutg/ChangeLog
index ae22f5ed03b5..e0662433f996 100644
--- a/sci-biology/cutg/ChangeLog
+++ b/sci-biology/cutg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/cutg
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/ChangeLog,v 1.52 2009/09/01 20:54:10 ribosome Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/ChangeLog,v 1.53 2010/03/07 20:50:00 jlec Exp $
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org> cutg-160.ebuild:
+ Moved to EAPI=3 for PREFIX support, imported prefix patches from overlay,
+ keyworded as in overlay
01 Sep 2009; Olivier Fisette <ribosome@gentoo.org> metadata.xml:
Giving up maintainership of this package.
diff --git a/sci-biology/cutg/cutg-160.ebuild b/sci-biology/cutg/cutg-160.ebuild
index 15525aa7685b..5dba4a6b4c31 100644
--- a/sci-biology/cutg/cutg-160.ebuild
+++ b/sci-biology/cutg/cutg-160.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/cutg-160.ebuild,v 1.2 2009/08/31 21:13:02 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/cutg-160.ebuild,v 1.3 2010/03/07 20:50:00 jlec Exp $
+
+EAPI="3"
DESCRIPTION="Codon usage tables calculated from GenBank"
LICENSE="public-domain"
@@ -11,7 +13,7 @@ SLOT="0"
# Minimal build keeps only the indexed files (if applicable) and the
# documentation. The non-indexed database is not installed.
IUSE="emboss minimal"
-KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
DEPEND="emboss? ( sci-biology/emboss )"
RDEPEND="${DEPEND}"
@@ -29,17 +31,17 @@ src_compile() {
src_install() {
if ! use minimal; then
- mkdir -p "${D}"usr/share/${PN}
- mv *.codon *.spsum "${D}"/usr/share/${PN} || die \
+ mkdir -p "${ED}"usr/share/${PN}
+ mv *.codon *.spsum "${ED}"/usr/share/${PN} || die \
"Installing raw CUTG database failed."
fi
dodoc README CODON_LABEL SPSUM_LABEL || die \
"Failed to install documentation."
if use emboss; then
- mkdir -p "${D}"/usr/share/EMBOSS/data/CODONS
+ mkdir -p "${ED}"/usr/share/EMBOSS/data/CODONS
cd CODONS
for file in *; do
- mv ${file} "${D}"/usr/share/EMBOSS/data/CODONS || die \
+ mv ${file} "${ED}"/usr/share/EMBOSS/data/CODONS || die \
"Installing the EMBOSS-indexed database failed."
done
fi
diff --git a/sci-biology/emboss/ChangeLog b/sci-biology/emboss/ChangeLog
index 4ca45c3a1162..de2ba5b04b60 100644
--- a/sci-biology/emboss/ChangeLog
+++ b/sci-biology/emboss/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/emboss
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.54 2009/09/01 21:57:55 ribosome Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.55 2010/03/07 20:58:42 jlec Exp $
+
+*emboss-6.1.0-r1 (07 Mar 2010)
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +emboss-6.1.0-r1.ebuild:
+ Moved to EAPI=3 for PREFIX support, imported prefix patches from overlay,
+ keyworded as in overlay
01 Sep 2009; Olivier Fisette <ribosome@gentoo.org> metadata.xml:
Giving up maintainership of this package.
diff --git a/sci-biology/emboss/emboss-6.1.0-r1.ebuild b/sci-biology/emboss/emboss-6.1.0-r1.ebuild
new file mode 100644
index 000000000000..485e5d25ddcd
--- /dev/null
+++ b/sci-biology/emboss/emboss-6.1.0-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/emboss-6.1.0-r1.ebuild,v 1.1 2010/03/07 20:58:42 jlec Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="The European Molecular Biology Open Software Suite - A sequence analysis package"
+HOMEPAGE="http://emboss.sourceforge.net/"
+SRC_URI="ftp://${PN}.open-bio.org/pub/EMBOSS/EMBOSS-${PV}.tar.gz"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="X png minimal"
+
+DEPEND="X? ( x11-libs/libXt )
+ png? (
+ sys-libs/zlib
+ media-libs/libpng
+ media-libs/gd
+ )
+ !minimal? (
+ sci-biology/primer3
+ sci-biology/clustalw
+ )"
+
+RDEPEND="${DEPEND}"
+
+PDEPEND="!minimal? (
+ sci-biology/aaindex
+ sci-biology/cutg
+ sci-biology/prints
+ sci-biology/prosite
+ >=sci-biology/rebase-707
+ sci-biology/transfac
+ )"
+
+S="${WORKDIR}/EMBOSS-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-5.0.0-as-needed.patch
+
+ local link_string="-lX11";
+ if use png; then
+ link_string="${link_string} -lgd -lpng"
+ fi
+ sed -e "s:PATCH_PLPLOT:${link_string}:" -i plplot/Makefile.in \
+ || die "Failed to patch ajax Makefile"
+}
+
+src_configure() {
+ EXTRA_CONF="--includedir=${ED}/usr/include/emboss"
+ ! use X && EXTRA_CONF="${EXTRA_CONF} --without-x"
+ ! use png && EXTRA_CONF="${EXTRA_CONF} --without-pngdriver"
+
+ econf ${EXTRA_CONF} || die
+ # Do not install the JEMBOSS component (the --without-java configure option
+ # does not work). JEMBOSS will eventually be available as a separate package.
+ sed -i -e "s/SUBDIRS = plplot ajax nucleus emboss test doc jemboss/SUBDIRS = plplot ajax nucleus emboss test doc/" \
+ Makefile || die
+}
+
+src_install() {
+ einstall || die "Failed to install program files."
+
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS \
+ || die "Failed to install documentation."
+ newdoc "${FILESDIR}"/${PN}-README.Gentoo-1 README.Gentoo \
+ || die "Failed to install Gentoo readme file."
+
+ # Install env file for setting libplplot and acd files path.
+ cat <<- EOF > 22emboss
+ # plplot libs dir
+ PLPLOT_LIB="${EPREFIX}/usr/share/EMBOSS/"
+ # ACD files location
+ EMBOSS_ACDROOT="${EPREFIX}/usr/share/EMBOSS/acd"
+ EOF
+ doenvd 22emboss || die "Failed to install environment file."
+
+ # Symlink preinstalled docs to "/usr/share/doc".
+ dosym /usr/share/EMBOSS/doc/manuals /usr/share/doc/${PF}/manuals || die
+ dosym /usr/share/EMBOSS/doc/programs /usr/share/doc/${PF}/programs || die
+ dosym /usr/share/EMBOSS/doc/tutorials /usr/share/doc/${PF}/tutorials || die
+ dosym /usr/share/EMBOSS/doc/html /usr/share/doc/${PF}/html || die
+
+ # Remove frestdist documentation conflicting with the EMBASSY philypnew
+ # package.
+ rm "${ED}"/usr/share/EMBOSS/doc/programs/text/frestdist.txt || \
+ die "Failed to remove duplicated documentation."
+
+ # Remove useless dummy files from the image.
+ rm "${ED}"/usr/share/EMBOSS/data/{AAINDEX,PRINTS,PROSITE,REBASE}/dummyfile \
+ || die "Failed to remove dummy files."
+
+ # Move the provided codon files to a different directory. This will avoid
+ # user confusion and file collisions on case-insensitive file systems (see
+ # bug #115446). This change is documented in "README.Gentoo".
+ mv "${ED}"/usr/share/EMBOSS/data/CODONS \
+ "${ED}"/usr/share/EMBOSS/data/CODONS.orig || \
+ die "Failed to move CODON directory."
+
+ # Move the provided restriction enzyme prototypes file to a different name.
+ # This avoids file collisions with versions of rebase that install their
+ # own enzyme prototypes file (see bug #118832).
+ mv "${ED}"/usr/share/EMBOSS/data/embossre.equ \
+ "${ED}"/usr/share/EMBOSS/data/embossre.equ.orig || \
+ die "Failed to move enzyme equivalence file."
+}
diff --git a/sci-biology/meme/ChangeLog b/sci-biology/meme/ChangeLog
index eead4aac10cd..e136263f8321 100644
--- a/sci-biology/meme/ChangeLog
+++ b/sci-biology/meme/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/meme
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/meme/ChangeLog,v 1.13 2010/01/03 14:12:59 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/meme/ChangeLog,v 1.14 2010/03/07 20:56:03 jlec Exp $
+
+*meme-4.3.0-r1 (07 Mar 2010)
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org> +meme-4.3.0-r1.ebuild:
+ Moved to EAPI=3 for PREFIX support, imported prefix patches from overlay,
+ keyworded as in overlay
03 Jan 2010; Pacho Ramos <pacho@gentoo.org> meme-4.3.0.ebuild:
amd64 stable, bug 298760
diff --git a/sci-biology/meme/meme-4.3.0-r1.ebuild b/sci-biology/meme/meme-4.3.0-r1.ebuild
new file mode 100644
index 000000000000..2b8bc777833a
--- /dev/null
+++ b/sci-biology/meme/meme-4.3.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/meme/meme-4.3.0-r1.ebuild,v 1.1 2010/03/07 20:56:03 jlec Exp $
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="The MEME/MAST system - Motif discovery and search"
+HOMEPAGE="http://meme.sdsc.edu/meme"
+SRC_URI="http://meme.nbcr.net/downloads/${PN}_${PV}.tar.gz"
+LICENSE="meme"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+IUSE="mpi"
+
+DEPEND="dev-libs/libxml2
+ dev-libs/libxslt
+ app-shells/tcsh
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}_${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.0.0-Makefile.am.patch
+ eautoreconf
+}
+
+src_configure() {
+ MY_PREFIX="${EROOT}opt/meme"
+ USE_DISABLE_MPI=""; if ! use mpi; then USE_DISABLE_MPI="--enable-serial"; fi
+ econf --prefix=$MY_PREFIX --sysconfdir=${MY_PREFIX}/etc \
+ --with-logs="${EROOT}var/log/meme" \
+ $USE_DISABLE_MPI
+ # $(use_enable openmp)
+}
+
+#pkg_setup() {
+ # generate meme group to restrict logging to /var/log/meme
+# enewgroup meme
+#}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Failed to install program files."
+ echo "PATH=${EPREFIX}/opt/${PN}/bin" > 99${PN}
+ doenvd 99${PN} || die
+ # allow logging only for members of meme group
+ # diropts -m 0770 -g meme -o root
+ diropts -m ugo+rwxt -o root
+ keepdir /var/log/meme
+}
+
+#pkg_postinst() {
+# einfo 'Log files are produced in the "/var/log/meme" directory. Users'
+# einfo 'need to be part of the meme group to use this facility.'
+#}
+
+src_test() {
+ # bug #297070
+ emake -j1 test || die "Regression tests failed."
+}
diff --git a/sci-biology/primer3/ChangeLog b/sci-biology/primer3/ChangeLog
index da40f6f2ea79..f70008b4d463 100644
--- a/sci-biology/primer3/ChangeLog
+++ b/sci-biology/primer3/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/primer3
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/primer3/ChangeLog,v 1.21 2009/09/01 16:07:03 ribosome Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/primer3/ChangeLog,v 1.22 2010/03/07 20:53:15 jlec Exp $
+
+*primer3-1.1.4-r1 (07 Mar 2010)
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +primer3-1.1.4-r1.ebuild:
+ Moved to EAPI=3 for PREFIX support, imported prefix patches from overlay,
+ keyworded as in overlay
01 Sep 2009; Olivier Fisette <ribosome@gentoo.org> primer3-1.1.4.ebuild:
Stabilised on x86 and amd64.
diff --git a/sci-biology/primer3/primer3-1.1.4-r1.ebuild b/sci-biology/primer3/primer3-1.1.4-r1.ebuild
new file mode 100644
index 000000000000..65e39e19f6f5
--- /dev/null
+++ b/sci-biology/primer3/primer3-1.1.4-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/primer3/primer3-1.1.4-r1.ebuild,v 1.1 2010/03/07 20:53:15 jlec Exp $
+
+EAPI="3"
+
+DESCRIPTION="Design primers for PCR reactions."
+HOMEPAGE="http://primer3.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="whitehead"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+
+RDEPEND=""
+
+S="${WORKDIR}/src"
+
+src_prepare() {
+ [[ ${CHOST} == *-darwin* ]] && \
+ sed -e "s:LIBOPTS ='-static':LIBOPTS =:" -i Makefile
+}
+
+src_compile() {
+ emake -e || die
+}
+
+src_test () {
+ make primer_test || die
+}
+
+src_install () {
+ dobin long_seq_tm_test ntdpal oligotm primer3_core || die \
+ "Could not install program."
+ dodoc ../{how-to-cite.txt,README.txt,example} || die \
+ "Could not install documentation."
+}