summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/cutg/cutg-160.ebuild')
-rw-r--r--sci-biology/cutg/cutg-160.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/sci-biology/cutg/cutg-160.ebuild b/sci-biology/cutg/cutg-160.ebuild
index 15525aa7685b..5dba4a6b4c31 100644
--- a/sci-biology/cutg/cutg-160.ebuild
+++ b/sci-biology/cutg/cutg-160.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/cutg-160.ebuild,v 1.2 2009/08/31 21:13:02 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cutg/cutg-160.ebuild,v 1.3 2010/03/07 20:50:00 jlec Exp $
+
+EAPI="3"
DESCRIPTION="Codon usage tables calculated from GenBank"
LICENSE="public-domain"
@@ -11,7 +13,7 @@ SLOT="0"
# Minimal build keeps only the indexed files (if applicable) and the
# documentation. The non-indexed database is not installed.
IUSE="emboss minimal"
-KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
DEPEND="emboss? ( sci-biology/emboss )"
RDEPEND="${DEPEND}"
@@ -29,17 +31,17 @@ src_compile() {
src_install() {
if ! use minimal; then
- mkdir -p "${D}"usr/share/${PN}
- mv *.codon *.spsum "${D}"/usr/share/${PN} || die \
+ mkdir -p "${ED}"usr/share/${PN}
+ mv *.codon *.spsum "${ED}"/usr/share/${PN} || die \
"Installing raw CUTG database failed."
fi
dodoc README CODON_LABEL SPSUM_LABEL || die \
"Failed to install documentation."
if use emboss; then
- mkdir -p "${D}"/usr/share/EMBOSS/data/CODONS
+ mkdir -p "${ED}"/usr/share/EMBOSS/data/CODONS
cd CODONS
for file in *; do
- mv ${file} "${D}"/usr/share/EMBOSS/data/CODONS || die \
+ mv ${file} "${ED}"/usr/share/EMBOSS/data/CODONS || die \
"Installing the EMBOSS-indexed database failed."
done
fi