summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-11-25 18:58:09 -0500
committerMike Gilbert <floppym@gentoo.org>2016-11-25 18:59:27 -0500
commit8f9ee6e4a2613a73c3a178d120e0e65e693a6c36 (patch)
tree895e3402b2f9b3de2687b8ed5ffcab02afd44ea1 /app-emulation/open-vm-tools
parentsys-devel/autoconf-archive: mark 2016.03.20-r1 arm64/hppa/ia64/m68k/ppc/ppc64... (diff)
downloadgentoo-8f9ee6e4a2613a73c3a178d120e0e65e693a6c36.tar.gz
gentoo-8f9ee6e4a2613a73c3a178d120e0e65e693a6c36.tar.bz2
gentoo-8f9ee6e4a2613a73c3a178d120e0e65e693a6c36.zip
app-emulation/open-vm-tools: add kernel config checks
Package-Manager: portage-2.3.2_p8
Diffstat (limited to 'app-emulation/open-vm-tools')
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-10.1.0.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/app-emulation/open-vm-tools/open-vm-tools-10.1.0.ebuild b/app-emulation/open-vm-tools/open-vm-tools-10.1.0.ebuild
index 11dd15e4ff89..6a3727d42238 100644
--- a/app-emulation/open-vm-tools/open-vm-tools-10.1.0.ebuild
+++ b/app-emulation/open-vm-tools/open-vm-tools-10.1.0.ebuild
@@ -59,6 +59,19 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}/open-vm-tools"
+pkg_setup() {
+ linux-info_get_any_version
+ local CONFIG_CHECK="~VMWARE_BALLOON ~VMWARE_PVSCSI ~VMXNET3"
+ use X && CONFIG_CHECK+=" ~DRM_VMWGFX"
+ kernel_is -lt 3 9 || CONFIG_CHECK+=" ~VMWARE_VMCI ~VMWARE_VMCI_VSOCKETS"
+ kernel_is -lt 3 || CONFIG_CHECK+=" ~FUSE_FS"
+ if use modules; then
+ linux-mod_pkg_setup
+ else
+ linux-info_pkg_setup
+ fi
+}
+
src_prepare() {
eapply -p2 "${FILESDIR}/10.1.0-vgauth.patch"
default